1.8+ Support is Here!

ItsDoodyTime
7 month(s) ago
2211

Hey gamers! Due to a high volume of requests back when the servers were online, we decided to add 1.8, 1.9, 1.10, and 1.11 to the list of supported versions for all of you PvP enjoyers!


However, this wasn't an easy thing to do, and it comes with a few challenges. The first and biggest challenge that we had to face was compatibility issues with our anticheat, to ensure it could understand and translate the packets that 1.8 players send to the server. Luckily, this was easier to deal with considering the fact that our anticheat's A.I can just learn on the fly, but the real issue was with the recent 1.20 updates and Bedrock Cross-Platform Play. Though we were able to make some progress on resolving these issues, we still had some complications that as a result G C Network will now only be supporting 1.8 - 1.19.4 and Cross-Platform Play will not be in development, until we can find a solution.


We are so sorry for the inconvenience, and we thank you for your continuous support and understanding!

Tags:

You need to be signed in to comment.

Releasing May 15th!

Hey gamers! G C Network is rel

G C Network Turns 7!

Hey gamers! This is a late (an

We Will Be Right Back!

Hey everyone! This is a short

WE NEED YOUR HELP!!

Hey everyone! This is a call (

Account Registration is Now Open!

This is going to be a very sho